Model Year, Time Owned, Mileage, Any Issues

Discussion in 'Renegade Chat' started by TWX, Feb 9, 2017.

  1. TrailDuck

    TrailDuck New Member

    Joined:
    Apr 28, 2015
    Messages:
    3
    Location:
    United States
    2015 TH with ~27k. No problems at all and I just ordered some 225/65r17 ko2's. Also haven't done any updates so hopefully my luck continues

    Sent from my SM-G920F using ToasterJeep mobile app
     
  2. glennuk

    glennuk New Member

    Joined:
    Feb 12, 2017
    Messages:
    20
    Location:
    Nottinghamshire,uk
    6 weeks old 1030 miles 2.0 diesel felt sluggish at first dealership said will get full power around 1000 miles and now it's hit a 1000 it's like someone's flicked a switch and now she's great and responsive the more I drive it the more I love it .no faults so far



    Sent from my iPad using ToasterJeep mobile app
     
    ppholton likes this.
  3. TheRedOx

    TheRedOx New Member

    Joined:
    Jun 5, 2016
    Messages:
    2
    Location:
    Warrenville, IL
    '15 TH - 17,000 miles - transmission replaced at 12K (took almost a month as they were on backorder)
     
  4. TWX

    TWX Active Member

    Joined:
    Apr 18, 2016
    Messages:
    212
    Media:
    31
    Albums:
    3
    Location:
    The Blast Furnace
    What were the symptoms that called for the replacement?
     
  5. TheRedOx

    TheRedOx New Member

    Joined:
    Jun 5, 2016
    Messages:
    2
    Location:
    Warrenville, IL
    It just kinda died on me going about 45mph. Notices came up on the dash about "service transmission" and I limped it into a grocery store - loss of power but it never actually stalled or anything. By the time I got out of the store and for the next day or so it was pretty much back to feeling normal. On the way to the dealer the service light actually went away but they decided it needed a new transmission. Now, it's really jerky in reverse and I should probably have that looked at.
     
  6. Breezy

    Breezy New Member

    Joined:
    Sep 21, 2016
    Messages:
    11
    Location:
    Georgia
    2016. Coming up on my 1 year in June! Mileage is 6,500. My only issue with my renny is that my A/C control knob lights are faulty and sometimes don't turn on. Anyone else have this problem?


    Sent from my iPhone using ToasterJeep mobile app
     
    JoshMo87 likes this.
  7. dj002

    dj002 New Member

    Joined:
    Dec 11, 2015
    Messages:
    16
    Location:
    Northern VA
    '15 Latitude, year and a half with 25,000 miles. Nothing major repaired so far. Two clunks that went away when technicians looked at it, and the proximity module for entry/lock faulted but there's no fix for it yet -- a reset has got it back working for now.

    Have had all the computer updates done as they came out when I was in for oil changes every 5,000 miles.


    Sent from my iPhone using ToasterJeep mobile app
     
  8. TWX

    TWX Active Member

    Joined:
    Apr 18, 2016
    Messages:
    212
    Media:
    31
    Albums:
    3
    Location:
    The Blast Furnace
    We're getting a hesitation. Wife didn't notice it but I found it extremely unsettling to get essentially no throttle response and then when I pushed harder for it to almost want to jackrabbit-off.

    We're also seeing it pull to the side a bit. Anyone had their alignment fixed under warranty?
     
  9. Dgr401

    Dgr401 Active Member

    Joined:
    Nov 21, 2015
    Messages:
    162
    Location:
    Rhode Island, USA
    I doubt they will do an alignment under warranty, considered normal wear. They might do it as a courtesy if you have a good dealer and low miles. My Latitude needed an alignment at about 25,000 and I had to pay for it.
     
  10. Jason Z

    Jason Z Active Member

    Joined:
    Feb 7, 2016
    Messages:
    157
    Location:
    Austin
    12month/12k mileage on the alignment warranty.

    @TrailHawk16 tpms resets on its own unless there's a problem. Like the tire people breaking a sensor for example. Reset is just set to pressure and drive.
     
  11. Moe-javeThawK

    Moe-javeThawK New Member

    Joined:
    May 8, 2017
    Messages:
    1
    Location:
    NorCal Bay Area
    Wife has a 16 Trailhawk bought 6/16 after 14,300 miles we've seen the dealership 4 times. First was update for the beats audio system which they ended up bricking the radio (300 miles on vehicle) waited 3 weeks for replacement radio, at this time we noticed the rumbling noise coming from the rear that many on forums have observed and on next trip to dealer reported (dealer verified the noise). Second trip was to install new radio which ended up not having the navigation activated nor could they activate so another radio was ordered. Third trip was to install the 2nd replacement radio which ended up working. Fourth trip (14,000 miles) was due to the car throwing service electronic parking break and airbag error, dealer replaced the seat belt buckle on both ends. After a year of going back and forth on a "fix" for the rear end noise the dealer finally let us know that the official fix from Chrysler was a new rear diff, that took an extra week for it to arrive and get installed. When the dealer called back they informed us that the noise was still present and that they had also replaced the driveshaft as the boot was torn (already?). Currently we are waiting for a representative from Chrysler/Jeep to come drive the vehicle and give let us know the next steps. Might just have to give up on this one and try to envoke lemon law. Other than that the renegade has worked flawlessly.
     
    DVB likes this.
  12. Jimmy Lee Smith

    Jimmy Lee Smith Active Member

    Joined:
    Apr 5, 2017
    Messages:
    172
    Location:
    Las Vegas Nevada
    It's crazy to me that so many people are having issues with their Renegades, I have a '15 Trailhawk with 14k on it, plenty of it off-road, and absolutely no issues.

    Sent from my SM-G920T using ToasterJeep mobile app
     
  13. Cwmt3

    Cwmt3 New Member

    Joined:
    Sep 13, 2015
    Messages:
    12
    Location:
    Ontario, Canada
    '15 north commando green, 50k kilometres. No issues, but a couple recalls like the hitch bolts. Time for new front pads this week.

    Sent from my E6653 using ToasterJeep mobile app
     
  14. TWX

    TWX Active Member

    Joined:
    Apr 18, 2016
    Messages:
    212
    Media:
    31
    Albums:
    3
    Location:
    The Blast Furnace
    You doing the pads yourself, or having a mechanic do them?
     
  15. Cwmt3

    Cwmt3 New Member

    Joined:
    Sep 13, 2015
    Messages:
    12
    Location:
    Ontario, Canada
    Myself for sure, my local parts store had to order the pads, installing later this week. Should go smooth.

    Sent from my E6653 using ToasterJeep mobile app
     

Share This Page